aboutsummaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 42c1b78..554d35a 100644
--- a/Makefile
+++ b/Makefile
@@ -9,8 +9,13 @@ debug: main.c
$(CC) -g main.c -o $(BIN) $(CFLAGS)
valgrind --leak-check=full ./$(BIN) foo bar
-test: test.c
- $(CC) test.c -o test $(CFLAGS) -lcurl
-
clean:
rm main *.o $(BIN) -v
+
+install: build
+ cp $(BIN) /usr/bin/
+ chmod 755 /usr/bin/$(BIN)
+
+uninstall:
+ rm /usr/bin/$(BIN)
+
Feel free to download, copy and edit any repo