aboutsummaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index bf3c585..42c1b78 100644
--- a/Makefile
+++ b/Makefile
@@ -1,8 +1,16 @@
CC = gcc
-CFLAGS=-std=c99 -pedantic-errors
+CFLAGS=-std=c99 -pedantic-errors -Wall
+BIN=cli-tube
build: main.c
- $(CC) $(CFLAGS) main.c -o main
+ $(CC) $(CFLAGS) main.c -o $(BIN)
debug: main.c
- $(CC) -g main.c -o main $(CFLAGS)
+ $(CC) -g main.c -o $(BIN) $(CFLAGS)
+ valgrind --leak-check=full ./$(BIN) foo bar
+
+test: test.c
+ $(CC) test.c -o test $(CFLAGS) -lcurl
+
+clean:
+ rm main *.o $(BIN) -v
Feel free to download, copy and edit any repo