diff options
author | jvech <jmvalenciae@unal.edu.co> | 2022-01-24 13:10:28 -0500 |
---|---|---|
committer | jvech <jmvalenciae@unal.edu.co> | 2022-01-24 13:10:28 -0500 |
commit | 2c7d72db92a00f653b5f5db77b1ce5bc22800a07 (patch) | |
tree | af3fc48dfe193f5f3d83e97fae7e8c0b7c3631f3 /Makefile | |
parent | 9bf647a224ffe3f18a19fd8957406bc4f3e111d2 (diff) |
It works, now lets add comments and documentation
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 14 |
1 files changed, 11 insertions, 3 deletions
@@ -1,8 +1,16 @@ CC = gcc -CFLAGS=-std=c99 -pedantic-errors +CFLAGS=-std=c99 -pedantic-errors -Wall +BIN=cli-tube build: main.c - $(CC) $(CFLAGS) main.c -o main + $(CC) $(CFLAGS) main.c -o $(BIN) debug: main.c - $(CC) -g main.c -o main $(CFLAGS) + $(CC) -g main.c -o $(BIN) $(CFLAGS) + valgrind --leak-check=full ./$(BIN) foo bar + +test: test.c + $(CC) test.c -o test $(CFLAGS) -lcurl + +clean: + rm main *.o $(BIN) -v |